OpenDocMan Discourse

Installation problem

hi
i have a mistake during the installation process
Ubuntu 16 on VPS
PHP 7.0.33-0ubuntu0.16.04.15
mysql Ver 14.14 Distrib 5.7.30

Web server ok, php ok PhpMyAdmin OK, Mysql Ok
opendocman 1.3.7 downloaded en extracted in /var/html/www/opendocman

access www.mydomain.com/opendocman
asked for creating Configuration file
next page explain parameters to have
click “let’s go” … -> nothing more

does’nt matter
i modify the Sample configuration file config-sample.php and specify my parameters
dbname
username
password
hostname to localhost;port=3306

save as config.php

create a database names opendocman with the right pasword !
import database.sql inside

then i can access using www.mydomain.com/opendocman the login page !!!
i try username “admin” with no password
and …
i have a blank page named www.mydomain.com/opendocman/index.php

what is the pb and the next step ?

thanks

after enabling php error log i have this error :slight_smile:

PHP Warning: fopen(/var/www/html/opendocman/vendor/owasp/csrf-protector-php/libs/csrf/…/…/log/06-2020.log): failed to open stream: Permission denied in /var/www/html/opendocman/vendor/owa$

and

PHP Fatal error: Uncaught logFileWriteError: OWASP CSRFProtector: Unable to write to the log file in /var/www/html/opendocman/vendor/owasp/csrf-protector-php/libs/csrf/csrfprotector.php:439

full stack trace :slight_smile:
/var/www/html/opendocman/vendor/owasp/csrf-protector-php/libs/csrf/csrfprotector.php(256): csrfProtector::logCSRFattack()
#1 /var/www/html/opendocman/vendor/owasp/csrf-protector-php/libs/csrf/csrfprotector.php(190): csrfProtector::failedValidationAction()
#2 /var/www/html/opendocman/vendor/owasp/csrf-protector-php/libs/csrf/csrfprotector.php(144): csrfProtector::authorizePost()
#3 /var/www/html/opendocman/functions.php(41): csrfProtector::init()
#4 /var/www/html/opendocman/odm-init.php(74): require_once(’/var/www/html/o…’)
#5 /var/www/html/opendocman/odm-load.php(48): require_once(’/var/www/html/o…’)
#6 /var/www/html/opendocman/index.php(51): require_once(’/var/www/html/o…’)
#7 {main}
thrown in /var/www/html/opendocman/vendor/owasp/csrf-protector-php/libs/csrf/csrfprotector.php on line 439

Solved …

2 problems :
i had to redo a chown -R on the opendocman directory after installation
i had to modify the “base_url” record into the “odm_setting” table of the database to replace http://localhost/opendocman by http://www.mydomain.com/opendocman
and the default password off “admin” is not empty but “admin”

thanks

1 Like
  1. I dont have a base_url in my db
  2. version = 1.3.7
    –Problem – blank page after installation

Hello, please try the latest release. There have been many fixes since 1.3.7.

Hi Guys, I have installed the latest version 1.4.0 and I appear to be missing the base_url line in my db… Should I install an earlier version and then upgrade or can someone tell me what to put in where (I am not good with db’s)

@paul1965 Little late but, base_url is now computed instead of being stored in the database. Have you tried one of the more recent releases?